Home » Server Options » Data Guard » Logs not applied on Standby
Logs not applied on Standby [message #177357] Wed, 14 June 2006 05:41 Go to next message
anurag078
Messages: 34
Registered: May 2006
Location: West Des Moines
Member

Hi Guys,

A silly question to you....

The below query is the one, I used in my standby database.

This database acts a standby for a RAC PROD database which has
2 instances and redo logs are identified by thread 1 and thread 2.
==================================================================
Break on thread# skip 1 ;

1 select * from (
2 select THREAD#,
3 SEQUENCE#,
4 APPLIED,
5 ARCHIVED,
6 STANDBY_DEST,
7 STATUS,
8 to_char(COMPLETION_TIME, 'MM-DD-YY-HH24:MI') "COMPLETION TIME",
9 to_char(sysdate, 'MM-DD-YY-HH24:MI') "CURRENT TIME"
10 from V$ARCHIVED_LOG
11 where THREAD# = 1
12 order by sequence# desc
13 )
14 where rownum <=20
15 UNION ALL
16 select * from (
17 SELECT THREAD#,
18 SEQUENCE#,
19 APPLIED,
20 ARCHIVED,
21 STANDBY_DEST,
22 STATUS,
23 to_char(COMPLETION_TIME, 'MM-DD-YY-HH24:MI') "COMPLETION TIME",
24 to_char(sysdate, 'MM-DD-YY-HH24:MI') "CURRENT TIME"
25 from V$ARCHIVED_LOG
26 where THREAD# = 2
27 order by sequence# desc
28 )
29* where rownum <=20

THREAD# SEQUENCE# APP ARC STA S COMPLETION TIM CURRENT TIME
---------- ---------- --- --- --- - -------------- --------------
1 29129 YES YES NO A 06-13-06-15:14 06-13-06-15:31
29128 YES YES NO A 06-13-06-15:16 06-13-06-15:31
29127 NO YES NO A 06-13-06-15:16 06-13-06-15:31
29127 YES YES NO A 06-13-06-15:16 06-13-06-15:31
29126 YES YES NO A 06-13-06-15:16 06-13-06-15:31
29125 YES YES NO A 06-13-06-15:15 06-13-06-15:31
29124 YES YES NO A 06-13-06-15:15 06-13-06-15:31
29123 YES YES NO A 06-13-06-15:15 06-13-06-15:31
29122 YES YES NO A 06-13-06-15:15 06-13-06-15:31
29121 NO YES NO A 06-13-06-15:15 06-13-06-15:31

2 354 YES YES NO A 06-13-06-15:24 06-13-06-15:31
353 YES YES NO A 06-13-06-15:17 06-13-06-15:31
352 YES YES NO A 06-13-06-15:20 06-13-06-15:31
351 YES YES NO A 06-13-06-15:20 06-13-06-15:31
350 YES YES NO A 06-13-06-15:19 06-13-06-15:31
349 YES YES NO A 06-13-06-15:19 06-13-06-15:31
348 YES YES NO A 06-13-06-15:15 06-13-06-15:31
347 YES YES NO A 06-13-06-15:15 06-13-06-15:31
346 YES YES NO A 06-13-06-15:15 06-13-06-15:31
======================================================================
My question is that

1. For the sequence number 29127 and 29121, the APPLIED column is showing as "NO", for thread 1.
Is this normal???
Why the logs were not applied on the standby?
The logs after this sequence numbers 29122-29126 and 29128-29129 have been successfully applied.

At this juncture, is the standby database is in sync with PROD??

Waiting for your valuable comments,


Best Regards,
Anurag

Re: Logs not applied on Standby [message #180516 is a reply to message #177357] Tue, 04 July 2006 00:50 Go to previous message
dlore
Messages: 6
Registered: June 2006
Location: Philippines
Junior Member

Hi Guru's,

I have same problem like Anurag, I have a log that was not applied on one of my standby database but the following logs were all successfully applied.. My concern is do my standby db still sync with my production db?..

This is my option on what to regarding my standby database. I'm planning to restore the log that was not applied, but a month ago have passed, maybe the transaction on that log was modified already by the succeeding logs.. And I'm not sure if that will work or that will sync my prod and standby db. Or I will choose to re-create my standby database again..

Please advise.. Or maybe you have great solution on our problem that you can share with us.. Thank in advance...

Regards,
~DLORE
Previous Topic: Datafiles on Standby Databases
Next Topic: Data guard using
Goto Forum:
  


Current Time: Mon Apr 06 04:43:28 CDT 2020