Home » Developer & Programmer » Precompilers, OCI & OCCI » problem with VS6 in console mode
icon9.gif  problem with VS6 in console mode [message #115118] Thu, 07 April 2005 10:19 Go to next message
just-in
Messages: 5
Registered: April 2005
Location: russia
Junior Member

I hsve s problem with compilation of OCCI application with VS c++ 6.0

1.I downloaded from site oracle client
2. Used their make file to copile from "dos emulation" my project and it really worked
3. then i decided to do the same from visual studio 6.0 but i couldn't use the same paraqmeters for compiler. IDE says link errors, when I managed to compile my project, sometimes I had errors where in window message said: error in memory. i need exact steps that help me simply compile common console application in VS6.0 IDE.

My make.bat file that works is:
cl -GX -DWIN32COMMON -I. -Ic:\include -I. -D_DLL -D_MT main.cpp demo2.cpp mappings.cpp mydemo.cpp /link /LIBPATH:c:\lib\msvs oci.lib msvcrt.lib msvcprt.lib oraocci10.lib /nod:libc

I can't use these params in VS6.0 IDE in graphic mode

Please help me and Thank you, if you read this message Smile)

icon6.gif  Re: problem with VS6 in console mode [message #115260 is a reply to message #115118] Fri, 08 April 2005 09:17 Go to previous message
just-in
Messages: 5
Registered: April 2005
Location: russia
Junior Member

I solved this trouble. I managed it with ctrl+F5. My application didn't work with button rebuild. If somebody knows options that I choose to manage it, send me letters on dimahp@mail.ru.
Previous Topic: OCILobCreateTemporary Error
Next Topic: query does not work
Goto Forum:
  


Current Time: Sun Aug 09 04:08:39 CDT 2020