Home » Infrastructure » Unix » mounting cdrom problem
mounting cdrom problem [message #98052] Wed, 07 January 2004 09:38 Go to next message
rasica
Messages: 2
Registered: January 2004
Junior Member
Hello,
i hv sco unix installed & when i try to mount my cdrom by giving
#mount /dev/cd0 /mnt
i get an error :
mount: cannot stat '/dev/cd0' : No such file or directory (error 2)
Can anybody please help me??? what may be the problem?? why this cannot stat & no such file error comes??
Please, if anybody knows the solution ....reply me...Thanking u in anticipation
Re: mounting cdrom problem [message #98066 is a reply to message #98052] Fri, 16 January 2004 05:43 Go to previous message
Abhirup
Messages: 2
Registered: January 2004
Junior Member
Hi Rasica,
I think your CDROM drive may have some problem. If you are on SCO Unixware 7.1 loaded and the CDROM device is installed properly, then you need to use the following syntax to mount the CDROM.

$ mount -F cdfs -oro /dev/cdrom/cdrom_device_name /cdrom_mount_point

The actual syntax is:

$ mount -F cdfs -oro "cdrom_device_name" "cdrom_mount_point"

For example: If I have to mount the cdrom at the mount point /mnt/cdrom and my cdrom device name is c0b2t0l0 and the device is installed in /dev/cdrom directory then my command line should be:

$ mount -F cdfs -oro /dev/cdrom/c0b2t0l0 /mnt/cdrom.

The above error comes if your CDROM drive is not installed properly or if you are not mentioning a proper CDROM device name or if you the mount point directory structure is not perfect.

To find the name of the CDROM device you can follow the following steps:

$ cd /dev/cdrom
$ ls
This displays your CDROM device name.

Hope this helps you. For any further query, mail me.

With regards,
Abhirup Haldar.
Previous Topic: installaing oracle 8i on sco unixware 7.1
Next Topic: Simple Shell Script Question
Goto Forum:
  


Current Time: Sun Sep 27 22:39:49 CDT 2020