Home » Developer & Programmer » Precompilers, OCI & OCCI » Conection Problem with Pro*c
Conection Problem with Pro*c [message #94434] Thu, 28 October 2004 21:33 Go to next message
alok
Messages: 12
Registered: December 2000
Junior Member


Hello Everyone!!!

I have a Server application written in pro*C. This application connects remotely with Oracle DataBase 9i running in redhat linux 8.0, using the oracle client 9.2.0.4.

My application fork serveral child process, and each one keep the connection with the database to server various requests.

But to my surprise after several transactions with the DataBase, the child process is locked waiting for answer from oracle, and all process are just in no response state without any error or any message. every now and then i restart the application it works as
fine. but again same problem ...

ocassionally i encounter with ORA- 03113 end of file on communication channel error message.

e.g i am using the following connection string "db_con" now,

EXEC SQL CONNECT :username IDENTIFIED BY :password AT :db_con USING :db_name;

Is there any additinal parameter i have to add in the connection string.

pls can anybody help me out ... what could be the issue with the oracle server or my client application.

thanx !!!
alok
Re: Conection Problem with Pro*c [message #94437 is a reply to message #94434] Fri, 29 October 2004 00:59 Go to previous message
Pedro
Messages: 8
Registered: October 2002
Junior Member
Hi.
well, Iīm just starting with Oracle and donīt know much about this... but have you edited the alert.log file?
I suppose that it will give you more information.

pedro.
Previous Topic: help
Next Topic: OCI, dynamic SQL statements, and ORA-03106
Goto Forum:
  


Current Time: Mon Nov 23 16:58:02 CST 2020