Home » Developer & Programmer » Forms » D2K
D2K [message #83842] Thu, 18 December 2003 17:31
GL Narayanan
Messages: 2
Registered: December 2003
Junior Member
I am experiencing a problem in oracle.
I hv surfed and talked to some people here but I am unable to get ans/
soln. Wd appreciate help/guide.

Thanking you in advance

We hd developed appln in Oracle Workgroup server 7.3
and D2k 2000 forms 4.5(rel 1.2) under win 98 and Reports 2.5(v1.2).As of now the Oracle server has been upgraded to 8.0.4 but the application is still the same.

Now we want to upgrade to Oracle 9i under Linux and appln to developer 9i.
I read somewhere that the appln should be first upgraded to D2k v6i then to 9i.

Tried to open the forms in it.
I am experiencing problems as follows:

1. The form has reference to another form for canvasses,windows,property classes,object groups etc.
While opening it says it cannot find the referenced objects while the reference form is available in the current directory.
I tried to re-reference it but after saving and opening again it says that the referenced form does not exist. I recompiled the forms also but again the problem persists.

In the help section of forms the foll. is said:
How do I upgrade application FORMB which has referenced objects from a library form FORMA?


Perform the following steps :

1 Produce an INP file for FORMA if you don't have one already.
You would use "IAC30 FORMA UN/PW" to do this.


3 Open FORMA.FMB from Form Builder 5.0, and choose FileSave As to the
database (may have to visit your preference screen to be given the
chance to save to the database).

4 Upgrade FORMB.FMB. During the upgrade, reference information
is still read from the *Forms 3.0 tables*.

5 When you subsequently Open or Generate FORMB.FMB from Form Builder 6.0,
Form Builder will expect to *now* find the reference information in the
Form Builder 6.0 database tables.
Note that in 6.0 you can reference from the file system as well as the database.
I do not understand what is "IAC30". There is no utility like that.
How do I upgrade INP to .Fmb,
Do I need Forms 5.0?

2. In the same form there are libraies attached. Again the problem is as above.

compiling and opening the forms in 9IDS gives variou serrors frm-10142, frm-90928 etc.

Iam at a loss on how to proceed.

Can u pl. help.

Thanks in advance.

GL Narayanan
Previous Topic: Current date & time
Next Topic: Reports:Limitings records to multiples of 3..
Goto Forum:

Current Time: Wed May 22 04:37:05 CDT 2024