Home » Developer & Programmer » Forms » ADD_LIST_ELEMENT
ADD_LIST_ELEMENT [message #78862] Thu, 21 March 2002 13:23 Go to next message
Tyler
Messages: 123
Registered: January 2002
Senior Member
I know that this looks a little scrambled, but the jist is trying to add the list element to the list on new form instance... with a MESSAGE() it is shown that the value is there... but it doesn't seem to want to go into the list??? Suggestions?

SELECT CLAS_CLAS_CODE INTO V_PARENT_CLAS_CODE FROM CLASS WHERE CLAS_CODE = :PRFE_PRCL_CLAS_CODE;

WHILE V_PARENT_CLAS_CODE IS NOT NULL
LOOP
OPEN CUR_CLAS_CODE;
LOOP
FETCH CUR_CLAS_CODE INTO V_FEAT_TEXT;
EXIT WHEN CUR_CLAS_CODE%NOTFOUND;
ADD_LIST_ELEMENT('FEAT_LST',1,v_feat_text,1);
END LOOP;
CLOSE CUR_CLAS_CODE;
SELECT CLAS_CLAS_CODE INTO V_PARENT_CLAS_CODE FROM CLASS WHERE CLAS_CODE = V_PARENT_CLAS_CODE;
END LOOP;
Re: ADD_LIST_ELEMENT [message #78867 is a reply to message #78862] Fri, 22 March 2002 01:40 Go to previous message
Amit
Messages: 166
Registered: February 1999
Senior Member
1. if u are adding more than one element using add_list_element then why should the index for the list element not change .
i mean the second arg should be a variable that shuould evaluate to list index for that item.

2.the third & fourth arg should be strings specifying value and label of the list element which i think u have not done.

3.do u get any error messages.
Previous Topic: Types of record groups
Next Topic: Re: faq and their answers on developer2000(6i)
Goto Forum:
  


Current Time: Wed May 27 18:37:24 CDT 2020