Home » Developer & Programmer » Forms » Urgent!! Please reply soon!!
Urgent!! Please reply soon!! [message #78805] Mon, 18 March 2002 08:03 Go to next message
Raj
Messages: 411
Registered: November 1998
Senior Member
Hi Everybody,

I wanted to know from the User group that how to send email, where recipients address contain dots(periods) and domain information, using OLE2 from Forms through outlook. It works fine if I pass in only recipient names.

Can anybody suggest any possible way to make this work
Your fast response will be highly appreciated.

Thanks in advance.

Raj Patel.
Re: Urgent!! Please reply soon!! [message #78806 is a reply to message #78805] Mon, 18 March 2002 08:56 Go to previous messageGo to next message
Raj
Messages: 411
Registered: November 1998
Senior Member
Just to see if my email address is working. If this one does not work then I can receive email at

rajpatel32599@cs.com

Thanks,

Raj.
Re: Urgent!! Please reply soon!! [message #78815 is a reply to message #78805] Mon, 18 March 2002 23:37 Go to previous messageGo to next message
pratap kumar tripathy
Messages: 660
Registered: January 2002
Senior Member
1. what is the exact error ?
2. what is the coding u r using(post the code if possible)
3. what is the email address look like ? can u give couple of example.
Re: Urgent!! Please reply soon!! [message #78836 is a reply to message #78805] Tue, 19 March 2002 06:00 Go to previous messageGo to next message
pratap kumar tripathy
Messages: 660
Registered: January 2002
Senior Member
Hi! Pratap,

Thank you so much for replying.

Before I answer all of your questions, note:
I remember long back I have used the full email address with domain information through my Delphi programs and it worked fine. So I have tried to send an email directly through outlook, which has nothing to do with the Oracle Forms and OLE2, and it did not work. It seems like our MS Exchange server administrator has change something lately, which I'll find out if they have. They have another email address for everybody in our intranet, so I'm using that now that works fine. I think the problem only occurs when I'm sending an email within the intranet.

However, I would still like to have your thoughts on this, would like to know if there are any restrictions with OLE2 or Oracle Forms.

Answers to your questions are as below:

First, there is no error!!

Second, here is the code:

DECLARE
objOutlook OLE2.OBJ_TYPE;
objMail OLE2.OBJ_TYPE;
objArg OLE2.LIST_TYPE;
BEGIN
objOutlook := OLE2.CREATE_OBJ('Outlook.Application');
objarg := OLE2.CREATE_ARGLIST;
OLE2.ADD_ARG(objarg,0);
objMail := OLE2.INVOKE_OBJ(objOutlook,'CreateItem',objarg);
OLE2.DESTROY_ARGLIST(objarg);

OLE2.SET_PROPERTY(objmail,'To', :TO);
OLE2.SET_PROPERTY(objmail,'Subject',:SUBJECT);
OLE2.SET_PROPERTY(objmail,'Body',:BODY);

OLE2.INVOKE(objmail,'Send');
OLE2.INVOKE(objmail,'Display');

OLE2.RELEASE_OBJ(objmail);
OLE2.RELEASE_OBJ(objOutlook);

Message('Your mail sent successfully...');
Message('Your mail sent successfully...');
END;

Third, example of the email address is as below:

rajesh.patel@usdoj.gov

so it is <firstname>.<lastname>@usdoj.gov

Thanks,

Raj.
Re: Urgent!! Please reply soon!! [message #78838 is a reply to message #78836] Tue, 19 March 2002 06:31 Go to previous message
pratap kumar tripathy
Messages: 660
Registered: January 2002
Senior Member
hi raj,

i am using exactly the same code over here, i do not any problem. i was using the mail_id previously e.g."pratap" and now i am using internet address e.g. "pratap@????.ltd.??.

so u have to change the addressing scheme in outlook. go to tools-->service and choose interenet address then click properities button and change the address

ask ur adminstrator to do so.if u still have problem then feel free to discuss

good luck!!!

cheers
pratap
Previous Topic: differenciating rows in multiline display
Next Topic: Re: Default WHERE String on New Form Instance
Goto Forum:
  


Current Time: Wed Jun 03 05:09:53 CDT 2020