Home » Fusion Middleware & Colab Suite » Weblogic & Application Server » InterConnect 9.0.2 Adapter Problem
InterConnect 9.0.2 Adapter Problem [message #76606] Sat, 01 February 2003 07:36 Go to next message
Giriraj
Messages: 3
Registered: April 2002
Junior Member
Hi,
I am using the topology 2 for the InterConnet. In which the repository resides on top of a Oracle 9i Database. I am using the synchornized invoke and implement method for the data transfer between the adapters.

I had created the repository and the adapters. I did the mapping using the iStudio. The things were going on smoothly. Data was getting transmitted between the respective parties.

Then a need for creation of a new Business Object arose.So I mapped the new Business Object in the iStudio with the Adapters stopped. Compiled the SQLs generated by the iStudio.

then when i started the adapters.
The following message is seen in the log when we start the adapters message is seen on both the publishing and implmenting

Immeditaely after the message for "db_bridge_reader_1 has connected to the db successfully" the following message is seen.

org.omg.CORBA.COMMM_FAILURe : minor code :0 completed : No
at com.visigenic.vbroker.ds.IStream. (IStream:java:16)
at com.visigenic.vbroker.DSUser$DatagramThread.run(DSUser.java:108)

what could be the corrective measure ? i repeat all the data which was being sent earlier is going properly even now. Can some one help me out quickly in very bad need of help

regards
Giriraj
Re: InterConnect 9.0.2 Adapter Problem [message #76620 is a reply to message #76606] Mon, 17 February 2003 04:51 Go to previous message
B Giriraj
Messages: 1
Registered: February 2003
Junior Member
hi i found this soultion, posting it so that someone else who is stuck with a similar problem can use it too

The adapters cache the metadata locally from the repository. When you added a new integration point in iStudio, that new metadata never made it to the adapter. The adapter is trying to contact the repository at runtime to get that metadata but cannot (that's where you're getting the CORBA error -- the adapter uses CORBA to contact the repository). To re-check your CORBA connection, do the following:

- Stop the adapters
- Go into the adapter directory for both adapters and delete the following two folders:
Persistence
Logs
- Start the repository (make sure it's properly started -- go into the repository directory and look at reposlog.txt -- it shouldn't have any errors)
- Start the adapters and make sure they connect to the repository (shouldn't see the error message)
- Start iStudio and connect to the repository. Go to the File Menu and select "Push Metadata", then click on the two adapters (holding the CTRL key on your keyboard to select both adapters), and click OK. This will push all the metadata (including the one for the new integration point) to the adapters.
-Retry sending the message


cheers
Giriraj
Previous Topic: Re: Oracle webdb download
Next Topic: Re: ORACLE CERTIFIED PROFESSIONAL TEST EXAM
Goto Forum:
  


Current Time: Sun Sep 27 22:31:12 CDT 2020