Home » Server Options » Replication » cannot add snapshot object to snapshot group
cannot add snapshot object to snapshot group [message #75031] Mon, 19 March 2001 08:41 Go to next message
Harry
Messages: 17
Registered: March 2001
Junior Member
hi there. i need someone with replication experience/troubleshooting to help me out.

my environment: RedHat 6.2 Oracle 8i 8.1.6 Standard Edition

the situation:

1. i have a single master site (PROD1) and one snapshot site (PROD2). the init.ora parameters are ok.

2. on master site (PROD1), i have created repadmin and granted all the priviledges. i created scott and had emp and dept. i created a master group (scott_mg) and add emp and dept into the master group successfully. i created snapshot log on emp and dept. i did a query on all_repobject and the status of all objects is valid.

3. my problem is on snapshot site (PROD2). i have same repadmin and scott, same priviledges and have created public and private db links. i logged in repadmin and scott and did a select * from scott.emp@PROD1 and it returned all the data. i created the snapshot group (scott_mg) by running the procedure "

SQL> begin
dbms_repcat.create_snapshot_repgroup (
gname=>'scott_mg',
master=>'PROD1',
propagation_mode=>'asynchronous');
end;
/ 2 3 4 5 6 7

PL/SQL procedure successfully completed.

however when i tried to create the snapshot i received the following error message:

SQL> begin
dbms_repcat.create_snapshot_repobject (
gname=>'scott_mg',
sname=>'scott',
oname=>'dept',
type=>'snapshot',
ddl_text=>'create snapshot scott.dept refresh fast start with sysdate next
sysdate + (1/1440) for update as select * from scott.dept@PROD1',
min_communication=>true);
end;
/ 2 3 4 5 6 7 8 9 10 11
begin
*
ERROR at line 1:
ORA-23308: object SCOTT.DEPT does not exist or is invalid
ORA-06512: at "SYS.DBMS_SYS_ERROR", line 95
ORA-06512: at "SYS.DBMS_REPCAT_SNA_UTL", line 4370
ORA-06512: at "SYS.DBMS_REPCAT_SNA_UTL", line 5158
ORA-06512: at "SYS.DBMS_REPCAT_SNA", line 82
ORA-06512: at "SYS.DBMS_REPCAT", line 1076
ORA-06512: at line 2

anyone please can tell me what's the possible problem in this case? your help is appreciated.

thanks

----------------------------------------------------------------------
Re: cannot add snapshot object to snapshot group [message #75070 is a reply to message #75031] Wed, 11 July 2001 03:26 Go to previous messageGo to next message
Sven
Messages: 10
Registered: July 2001
Junior Member
Hi,

any solutions to this problem?
We get the same error message although everything looks OK.

Regards
Sven

----------------------------------------------------------------------
Re: cannot add snapshot object to snapshot group [message #75083 is a reply to message #75070] Mon, 30 July 2001 04:45 Go to previous message
Daniel
Messages: 47
Registered: February 2000
Member
We got the same message (ORA-23308). Other people said me that pdf docs of Oracle 8i replication have some errors, and, possibly, we had to create some db links pointing to snapshot site in the master site too. I have seen some scripts created for Oracle7 replication. you can find it in

http://database.sarang.net/database/oracle/oracle-general/updatable-snapshot.txt

----------------------------------------------------------------------
Previous Topic: replication with data transformations
Next Topic: Re: Replicating a Database to a Remote server
Goto Forum:
  


Current Time: Fri Oct 30 00:32:31 CDT 2020