Home » RDBMS Server » Performance Tuning » how to increase max_processes?
how to increase max_processes? [message #64759] Thu, 22 January 2004 19:57 Go to next message
Amit Jain
Messages: 2
Registered: January 2004
Junior Member
ctually we are running out of processes. Whenever we are running our Forms and using Databases it is running of processes.
It displays the message Max no. of Proceeses 150 exceeded now what i did is that i make changes to init.ora file and increments the no. of processes to 300 but it didn't work as i give

show processes

it says processes to 150 only.

Now do that changes to increment no. of processes to 300 doesn't work or somewhere else it is required to be updated too.
while it shows processes in init.ora to be 300 only but it is not updating in

show processes

even after the restart of database several times.
changes are there in init.ora but not reflecting in actual database.
i don't know why?

Ques : How to increase the max no. of processes
Re: how to increase max_processes? [message #64761 is a reply to message #64759] Thu, 22 January 2004 20:44 Go to previous messageGo to next message
Shesh
Messages: 16
Registered: July 2003
Junior Member
Which version of Oracle you are using?
If it is above 9 then give
'Alter system set processes=300 scope=spfile;'
and restart the database.
Re: how to increase max_processes? [message #64763 is a reply to message #64761] Thu, 22 January 2004 21:09 Go to previous messageGo to next message
Amit Jain
Messages: 2
Registered: January 2004
Junior Member
Yes I do have Oracle Database 9i and I have initially run the command specified by you an restart the server several times but it is not reflecting any of the changes.I am unable to understand why it is reacting this way.

Is memory any issue in it as I do have 2GB of memory.
Re: how to increase max_processes? [message #64764 is a reply to message #64763] Fri, 23 January 2004 02:27 Go to previous messageGo to next message
Shesh
Messages: 16
Registered: July 2003
Junior Member
I don't know what's the problem.
You can try one thing.
Create a pfile using ur existing spfile
'Create Pfile from Spfile;'
Take this pfile and edit the value for parameter 'Processes'.
Start the database using this pfile.
'Startup Pfile='<path>'
Again u create spfile by using
'create spfile from pfile'.
Now restart the database without pfile(Using SPfile)

Hope this will solve ur problem.
Re: how to increase max_processes? [message #64766 is a reply to message #64763] Fri, 23 January 2004 13:03 Go to previous message
Thiru
Messages: 1089
Registered: May 2002
Senior Member
Post us the screen shot of your sqlplus session when you are changing the parameter,bouncing the instance and displaying the process value from V$parameter,v$spparameter,v$system_parameter.

Also OS/Oracle version and kernel parameters(semmns,semmsl for Unix).

-Thiru
Previous Topic: This query is running forever - urgent help pls
Next Topic: splitting datafiles
Goto Forum:
  


Current Time: Wed Sep 30 11:41:19 CDT 2020