Home » Server Options » RAC & Failsafe » Private IPs are not Pingable from Node1 to Node2 :x (VirtualBox 6.0.4)
Private IPs are not Pingable from Node1 to Node2 :x [message #675141] Tue, 12 March 2019 08:09 Go to next message
dbalex407
Messages: 7
Registered: March 2019
Junior Member
Hello RAC GURUS!!!

I am having a problem that only you can solve. I am running windows 10. and using VirtualBox 6.0.4


I have the wireless bridge adapter set up. 2 Adapters are enabled >> Allow Promiscuous Mode >> Cable Connected. I have the Linux FW disabled, as well as my windows firewall and have NO antivirus programs installed. I did enable the NAT as a 3rd wireless adapter to cheat to connect to the hostnames to download the yum installer, but I have disabled it and cannot ping to my private networks Below are images of my specs and description of my problem.


I have searched all over google and plenty of forums. I can ping out to any website using the ip, but I cannot ping to any hostnames like google etc. Also when I try to do the yum command: yum -y install oracle-rdbms*

I receive the error:



public-yum.oracle.com/repo/OracleLinux/OL6/UEKR3/latest/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'public-yum.oracle'"

Trying other mirror.

Error: Cannot retrieve repository metadata (repomd.xml) for repository: public_ol6_UEKR3_latest. Please verify its path and try again



If it was an ip it would work, but for some reason I cannot connect to any hostname using the ip. Why is this? Is their a plugin I need to download to connect my bridge network for my dns to work?


In the image attached you can see that my future rac servers can talk to each other publicly but cannot ping any hostnames or priv ips


/foru/forum/fa/14060/0/



Any help will be greatly appreciated. I'm so close I can feel it!!!

PS. I have not even got around to installing the Oracle software on my nodes yet bc I am having trouble with the networking, I have only done the yum preqs.


Re: Private IPs are not Pingable from Node1 to Node2 :x [message #675142 is a reply to message #675141] Tue, 12 March 2019 08:12 Go to previous messageGo to next message
BlackSwan
Messages: 26730
Registered: January 2009
Location: SoCal
Senior Member
Welcome to this forum

Please read and follow the forum guidelines, to enable us to help you:
OraFAQ Forum Guide
How to use {code} tags and make your code easier to read
Private IPs are not Pingable from Node1 to Node2 :x [message #675143 is a reply to message #675141] Tue, 12 March 2019 08:19 Go to previous messageGo to next message
dbalex407
Messages: 7
Registered: March 2019
Junior Member
Hello RAC GURUS!!!

I am having a problem that only you can solve. I am running windows 10. and using VirtualBox 6.0.4


I have the wireless bridge adapter set up. 2 Adapters are enabled >> Allow Promiscuous Mode >> Cable Connected. I have the Linux FW disabled, as well as my windows firewall and have NO antivirus programs installed. I did enable the NAT as a 3rd wireless adapter to cheat to connect to the hostnames to download the yum installer, but I have disabled it and cannot ping to my private networks Below are images of my specs and description of my problem.


I have searched all over google and plenty of forums. I can ping out to any website using the ip, but I cannot ping to any hostnames like google.com etc. Also when I try to do the yum command: yum -y install oracle-rdbms*

I receive the error:



http://public-yum.oracle.com/repo/OracleLinux/OL6/UEKR3/latest/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host 'public-yum.oracle.com'"

Trying other mirror.

Error: Cannot retrieve repository metadata (repomd.xml) for repository: public_ol6_UEKR3_latest. Please verify its path and try again



If it was an ip it would work, but for some reason I cannot connect to any hostname using the ip. Why is this? Is their a plugin I need to download to connect my bridge network for my dns to work?


In the image attached you can see that my future rac servers can talk to each other publicly but cannot ping any hostnames or priv ips


https://community.oracle.com/servlet/JiveServlet/showImage/2-15088916-703254/rac+networking+barely+working.png

https://community.oracle.com/servlet/JiveServlet/showImage/2-15088916-703255/orarac+practice.png

https://community.oracle.com/servlet/JiveServlet/showImage/2-15088916-703256/orarac1.png

https://community.oracle.com/servlet/JiveServlet/showImage/2-15088916-703260/orarac2.png

https://community.oracle.com/servlet/JiveServlet/showImage/2-15088916-703262/orarac+etchosts.png



Any help will be greatly appreciated. I'm so close I can feel it!!!

PS. I have not even got around to installing the Oracle software on my nodes yet bc I am having trouble with the networking, I have only done the yum preqs.


Re: Private IPs are not Pingable from Node1 to Node2 :x [message #675144 is a reply to message #675142] Tue, 12 March 2019 08:20 Go to previous messageGo to next message
dbalex407
Messages: 7
Registered: March 2019
Junior Member
@BlackSwan Thank you sir!

[Updated on: Tue, 12 March 2019 08:22]

Report message to a moderator

Re: Private IPs are not Pingable from Node1 to Node2 :x [message #675145 is a reply to message #675144] Tue, 12 March 2019 08:23 Go to previous messageGo to next message
BlackSwan
Messages: 26730
Registered: January 2009
Location: SoCal
Senior Member
We don't like to delete threads so I have merged the two threads.
We can cope with a little redundancy.
Re: Private IPs are not Pingable from Node1 to Node2 :x [message #675146 is a reply to message #675145] Tue, 12 March 2019 08:27 Go to previous messageGo to next message
dbalex407
Messages: 7
Registered: March 2019
Junior Member
no worries. There's always a workaround Smile
Re: Private IPs are not Pingable from Node1 to Node2 :x [message #675147 is a reply to message #675143] Tue, 12 March 2019 08:32 Go to previous messageGo to next message
John Watson
Messages: 8309
Registered: January 2010
Location: Global Village
Senior Member
I always use host-only network for all the NICs when configuring RAC, and disable the VB DHCP server, and run my own DNS on a third VM. The way you have done it looks horribly confused.
Re: Private IPs are not Pingable from Node1 to Node2 :x [message #675148 is a reply to message #675147] Tue, 12 March 2019 08:41 Go to previous message
dbalex407
Messages: 7
Registered: March 2019
Junior Member
@John that sounds highly advanced. However if I can't figure this out then I will probably have to go that route. Do you have any suggestions or guides you referred to when you were learning your RAC Configuration? And thanks for the quick reply.
Previous Topic: Cannot copy asm to filesystem when login as sysdba
Next Topic: ORA-04022: nowait requested, but had to wait to lock dictionary object
Goto Forum:
  


Current Time: Mon Aug 03 07:24:47 CDT 2020