Home » Developer & Programmer » Forms » FORMS (10.1.2.0)
FORMS [message #634486] Tue, 10 March 2015 10:11 Go to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
running Oracle in Windows XP mode thru Windows Virtual pc.
Installed Oracle db version 10. sqlplus no problem.
Installed Oracle Forms and reports - version 10.1.2.0
When I try to create a form and log in I get the message:

FRM-10142 The HTTP listener is not running.
If I check the status of the Listener, I get the following error:

LSNRCTL> status
Connecting to (ADDRESS=(PROTOCOL=tcp)(PORT=152
TNS-12541: TNS:no listener
TNS-12560: TNS:protocol adapter error
TNS-00511: No listener
32-bit Windows Error: 61: Unknown error
LSNRCTL>


If I stop and start the Listener, I get the following error:
LSNRCTL> stop
Connecting to (ADDRESS=(PROTOCOL=tcp)(PORT=1521))
TNS-12541: TNS:no listener
TNS-12560: TNS:protocol adapter error
TNS-00511: No listener
32-bit Windows Error: 61: Unknown error
LSNRCTL> start
Starting tnslsnr: please wait...

Failed to start service, error 2.
TNS-12560: TNS:protocol adapter error
TNS-00530: Protocol adapter error

LSNRCTL>
**********************************
If I go back to SQL PLUS and try to log in I get the following
ERROR: ORA-12541: TNS:no listener

Here is a copy of my TNSNAMES.ORA and Listener.ora file:

# tnsnames.ora Network Configuration File: C:\oracle\DevSuiteHome_1\network\admin\tnsnames.ora
# Generated by Oracle configuration tools.

ORCL =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = VirtualXP-20999)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SERVICE_NAME = orcl)
)
)

listener.ora file

# listener.ora Network Configuration File: C:\oracle\product\10.2.0\db_1\network\admin\listener.ora
# Generated by Oracle configuration tools.

LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
(ADDRESS = (PROTOCOL = TCP)(HOST = VirtualXP-20999)(PORT = 1521))
)
)



SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(SID_NAME = PLSExtProc)
(ORACLE_HOME = C:\oracle\product\10.2.0\db_1)
(PROGRAM = extproc)
)
)



EXTPROC_CONNECTION_DATA =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = VirtualXP-20999)(PORT = 1521))
)
(CONNECT_DATA =
(SERVICE_NAME = PLSExtProc)
)
)




[Updated on: Tue, 10 March 2015 10:14]

Report message to a moderator

Re: FORMS [message #634491 is a reply to message #634486] Tue, 10 March 2015 15:37 Go to previous messageGo to next message
Littlefoot
Messages: 21578
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
This:
GUPPY6970

FRM-10142 The HTTP listener is not running.

usually means that you didn't start OC4J instance. You'll find it in Start - All programs - Oracle ... - Forms (copy it, as well as "Stop OC4J", to the Desktop; it is easier to start/stop it there). Once you start it, can you run the form?
Re: FORMS [message #634492 is a reply to message #634491] Tue, 10 March 2015 15:42 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
I started OC4J instance after I got the error, than checked and stopped and started the Listener.
Re: FORMS [message #634494 is a reply to message #634492] Tue, 10 March 2015 16:03 Go to previous messageGo to next message
Littlefoot
Messages: 21578
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Does it mean that you still can't run the form?

Can you log on to the database, or does it fail as well?
Re: FORMS [message #634496 is a reply to message #634494] Tue, 10 March 2015 17:41 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
I can not run the form.
I get the message:
FRM-10142 The HTTP listener is not running.

If I go in with sqlplus I get the following:
ERROR: ORA-12541: TNS:no listener

Re: FORMS [message #634513 is a reply to message #634496] Wed, 11 March 2015 02:08 Go to previous messageGo to next message
Littlefoot
Messages: 21578
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Some more info about ORA-12541 (along with instructions how to fix it).
Re: FORMS [message #634656 is a reply to message #634513] Thu, 12 March 2015 10:58 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
I went into ORA-12541 and tried the suggestions.
My SQLPLUS and Reportbuilder now works correctly.
When I go into forms I get the following error:
FRM-10142 Listener is not running at port 8889.
Please start the listener or check your runtime preferences.

My runtime preferences are set in the Application Server url and Web Browser Location
The only thing that I can not find in the General tab is the Color Palette- I can not fine the color directory.
********************************************************************
If I go to the Listener and check the status I get the following:

LSNRCTL> status
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=VirtualXP-20999)(PORT=1521)))
STATUS of the LISTENER
------------------------
Alias LISTENER
Version TNSLSNR for 32-bit Windows: Version 10.2.0.1.0 - Production
Start Date 12-MAR-2015 11:06:26
Uptime 0 days 0 hr. 22 min. 48 sec
Trace Level off
Security ON: Local OS Authentication
SNMP OFF
Listener Parameter File C:\oracle\product\10.2.0\db_1\network\admin\listener.ora
Listener Log File C:\oracle\product\10.2.0\db_1\network\log\listener.log

Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1ipc)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=VirtualXP-20999)(PORT=1521)))
Services Summary...
Service "PLSExtProc" has 1 instance(s).
Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
Service "orcl" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Service "orclXDB" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Service "orcl_XPT" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
The command completed successfully
****************************************************
If I stop the listener, I get:
LSNRCTL> stop
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=VirtualXP-20239)(PORT=1521)))
The command completed successfully
*****************************************************
When I start the Listener I get:
LSNRCTL> start
Starting tnslsnr: please wait...

Failed to start service, error 2.
TNS-12560: TNS:protocol adapter error
TNS-00530: Protocol adapter error

LSNRCTL>












Re: FORMS [message #634658 is a reply to message #634656] Thu, 12 March 2015 11:33 Go to previous messageGo to next message
gazzag
Messages: 1082
Registered: November 2010
Location: Bristol, UK
Senior Member
You're confusing the Oracle Listener with the HTTP one. You stopped the Oracle listener here:
If I stop the listener, I get:
LSNRCTL> stop
Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=VirtualXP-20239)(PORT=1521)))
The command completed successfully

Try starting the database listener using the Services applet under Control Panel.
Re: FORMS [message #634668 is a reply to message #634658] Thu, 12 March 2015 13:33 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
In services, I started OracleOradb10G_home1TNSListener and it shows STARTED.

There are 2 others, OracleDevSuiteHome1TNSListener and
OracleDevSuiteHome2TNSListener both show Automatic with no status.

If I try to start them I get the error:
Could not start the OracleDevSuiteHome1TNSListener service on the Local Computer. Error 2: The system cannot find the file specified:

Could not start the OracleDevSuiteHome2TNSListener service on the Local Computer. Error 2: The system cannot find the file specified:

When I go back into forms, I still get the error FRM:10142.

Should I delete OracleDevSuiteHome1TNSListener and OracleDevSuiteHome2TNSListener services?

[Updated on: Thu, 12 March 2015 13:47]

Report message to a moderator

Re: FORMS [message #634690 is a reply to message #634668] Fri, 13 March 2015 05:24 Go to previous messageGo to next message
gazzag
Messages: 1082
Registered: November 2010
Location: Bristol, UK
Senior Member
What are the services starting with the word "Oracle" in the services applet, and what are their statuses?
Re: FORMS [message #634696 is a reply to message #634690] Fri, 13 March 2015 07:29 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
Name Status Startup Type
****************************************************
OracleDbConsoleorcl Started Automatic
OracleDevSuiteHome1TNSListener Blank Automatic
OracleJobSchedulerORCL Blank Disabled
OracleOraDb10g_home1isql*plus Started Automatic
OralcedORA10G_HOME1tnslistener Started Automatic
OracleServiceORCL Started Automatic


OracleDevSuiteHome2TNSListener does not show up any more
Re: FORMS [message #634699 is a reply to message #634696] Fri, 13 March 2015 08:39 Go to previous messageGo to next message
gazzag
Messages: 1082
Registered: November 2010
Location: Bristol, UK
Senior Member
Have you started your OC4J instance again?
Re: FORMS [message #634700 is a reply to message #634699] Fri, 13 March 2015 09:10 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
I did start the OC4J instance.
I loaded the form and logged in and got the error FRM-10142.

I checked the listener status and it shows:

C:\>lsnrctl status

LSNRCTL for 32-bit Windows: Version 10.2.0.1.0 - Production on 13-MAR-2015 10:08:40

Copyright (c) 1991, 2005, Oracle. All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1)))
STATUS of the LISTENER
------------------------
Alias LISTENER
Version TNSLSNR for 32-bit Windows: Version 10.2.0.1.0 -Production
Start Date 12-MAR-2015 14:19:36
Uptime 0 days 19 hr. 49 min. 3 sec
Trace Level off
Security ON: Local OS Authentication
SNMP OFF
Listener Parameter File C:\oracle\product\10.2.0\db_1\network\admin\listener.ora
Listener Log File C:\oracle\product\10.2.0\db_1\network\log\listener.log

Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1ipc)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=VirtualXP-20239)(PORT=1521)))
Services Summary...
Service "PLSExtProc" has 1 instance(s).
Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
Service "orcl" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Service "orclXDB" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
Service "orcl_XPT" has 1 instance(s).
Instance "orcl", status READY, has 1 handler(s) for this service...
The command completed successfully

C:\>

Re: FORMS [message #634701 is a reply to message #634700] Fri, 13 March 2015 09:15 Go to previous messageGo to next message
gazzag
Messages: 1082
Registered: November 2010
Location: Bristol, UK
Senior Member
What do you see if you browse to this URL?
http://localhost:8888
Re: FORMS [message #634704 is a reply to message #634701] Fri, 13 March 2015 10:00 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
Tried http://localhost:8888 in Internet Explorer and Firefox and get the same results in both:

Can not display webpage in Internet Explorer
Unable to connect in Firefox
Re: FORMS [message #634743 is a reply to message #634704] Sat, 14 March 2015 09:06 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
In the Windows Task Manager,TNSLSNR.EXE shows that it is running.
Should the OC4J instance show up in the Windows Task Manager? It is not showing up.
When I run the form, with the error FRM-10142 it shows the listener at port 8889.
I tried http://localhost:8889 with the same results.

Re: FORMS [message #634835 is a reply to message #634743] Mon, 16 March 2015 11:14 Go to previous messageGo to next message
CraigB
Messages: 386
Registered: August 2014
Location: Utah, USA
Senior Member
Quote:
Should the OC4J instance show up in the Windows Task Manager? It is not showing up.

Have you manually started the OC4J Instance? If not, it will not automatically start unless you have added it to your "Start up". There is a Start Menu option to "Start the OC4J" in one of the Oracle Program Groups that was added during installation.

Craig...
Re: FORMS [message #634839 is a reply to message #634743] Mon, 16 March 2015 11:22 Go to previous messageGo to next message
gazzag
Messages: 1082
Registered: November 2010
Location: Bristol, UK
Senior Member
Quote:
In the Windows Task Manager,TNSLSNR.EXE shows that it is running.

That is the Oracle database listener. It is unrelated to your HTTP listener.
Quote:

Should the OC4J instance show up in the Windows Task Manager?

No, it will be run as a java process. Does "java.exe" appear in your Task Manager?
Re: FORMS [message #634847 is a reply to message #634839] Mon, 16 March 2015 15:09 Go to previous messageGo to next message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
java.exe does appear in my Task Manager
Re: FORMS [message #635723 is a reply to message #634839] Tue, 07 April 2015 09:15 Go to previous messageGo to next message
fatfish
Messages: 20
Registered: January 2015
Junior Member
I had the same problem.
I uninstalled and deleted devsuitehome_1 and re-installed it.
Make sure that the two TNSNAMES.ORA files are the same (One was missing the ORCL connection).
Created a form with no problem.

Re: FORMS [message #635724 is a reply to message #635723] Tue, 07 April 2015 10:48 Go to previous message
GUPPY6970
Messages: 18
Registered: March 2015
Junior Member
Tried it, works great.
Thanks for the help...
Previous Topic: Query running slow in Form but fast in DB
Next Topic: frm 40508 and ORA-01403: no data found
Goto Forum:
  


Current Time: Mon Aug 03 07:47:48 CDT 2020