Home » Server Options » Replication » Golden Gate Replication : Error while using Column with white space (and special character) (Golden Gate 11gR2 - Oracle 11gR2 and SQL Server 2008 Enterprise Edition)
Golden Gate Replication : Error while using Column with white space (and special character) [message #621585] Thu, 14 August 2014 12:05 Go to next message
Kaustubham
Messages: 5
Registered: August 2014
Junior Member
Hi

We are trying to replicate data from SQL Server to Oracle database
one of the columns in SQL Server database is having white space in the column name and it is producing errors during column mapping
(Error : Error with default mapping. No matching fields found in source and target)

I tried enclosing the column name in double quotes, in single quotes but no luck!

I also tried using the parameter USEANSISQLQUOTES & NOUSEANSISQLQUOTES in globals.prm but that too did not work for me

The 12g document suggests using double quotes
http://docs.oracle.com/goldengate/1212/gg-winux/GWUAD/wu_gettingstarted.htm#i1074957

But I am using 11g and in that case instead of mapping the column as mentioed in the double quotes it is assigned as value of the column in target table

map dbo.spl_data_types3, target app_owner.spl_data_types3, COLMAP(USEDEFAULTS, First_Name = "First Name");

Could you please suggest on this?

Kind Regards
Kaustubh
Re: Golden Gate Replication : Error while using Column with white space (and special character) [message #621591 is a reply to message #621585] Thu, 14 August 2014 13:05 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member

USEANSISQLQUOTES - When you add in GLOBAL.prm what was the error reported ?
Re: Golden Gate Replication : Error while using Column with white space (and special character) [message #621634 is a reply to message #621591] Fri, 15 August 2014 03:40 Go to previous messageGo to next message
Kaustubham
Messages: 5
Registered: August 2014
Junior Member
Hello babuknb

Thanks for your reply

Adding USEANSISQLQUOTES parameter simply did not made any difference

with USEANSISQLQUOTES in globals.prm and with column name enclosed in double quotes it treated the column name as literal values

Just same as what it was behaving when the parameter was not mentioned

If the double quotes are replaced by single quotes I get following errors
1) Error with default mapping. No matching fields found in source and target
2) Error in COLMAP (I did not record the error number; But when googled I noticed it's very generic error message

Thanks and Regards
Kaustubham



Re: Golden Gate Replication : Error while using Column with white space (and special character) [message #621773 is a reply to message #621634] Mon, 18 August 2014 03:34 Go to previous messageGo to next message
Kaustubham
Messages: 5
Registered: August 2014
Junior Member
Hello

This problem is resolved

I was creating the GLOBALS.prm in dirprm which in fact is needed in Golden Gate software directory

Rather than GGSCI I created the file manually

Thus the parameter 'USEANSISQLQUOTES' resolved issues as far as 'space in column name, special characters in column name' are concerned

However it did not resolve issue where tablename starts with number e.g. 01520Appdata

The double quotes, bracket as well as parameter 'USEANSISQLQUOTES' has not helped so far on this

I don't know if Golden Gate supports table names with number

I will start a separate thread for this.

Thanks and Regards
Kaustubham




Re: Golden Gate Replication : Error while using Column with white space (and special character) [message #621814 is a reply to message #621773] Mon, 18 August 2014 10:45 Go to previous message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member

Thank you for letting knows this...

>>However it did not resolve issue where tablename starts with number e.g. 01520Appdata

Are you sure you have tried with double quotes ? Hope you knows, In oracle if you want to create table name as 01520Appdata then you should use double quote like "01520Appdata"

SQL> create table 01520Appdata ( a int);
create table 01520Appdata ( a int)
             *
ERROR at line 1:
ORA-00903: invalid table name


SQL> create table "01520Appdata" ( a int);

Table created.

SQL> select * from 01520Appdata;
select * from 01520Appdata
              *
ERROR at line 1:
ORA-00903: invalid table name


SQL> select * from "01520Appdata";

no rows selected
Previous Topic: What is the cost
Next Topic: Does Golden Gate support Table name starting with number?
Goto Forum:
  


Current Time: Thu Sep 24 10:58:18 CDT 2020