Home » Server Options » RAC & Failsafe » oracle 10g TAF fails for TOAD (Oracle 10g DB Server, 10.2.0.5.0, Win 2003 Enterprise Edition SP2)
oracle 10g TAF fails for TOAD [message #526098] Sat, 08 October 2011 03:47 Go to next message
mmaz2002
Messages: 11
Registered: October 2011
Location: India
Junior Member
Hello All,

We are into pre-production stage for Oracle RAC implementation. I have setup Oracle 10g 2 node RAC, currently i have been experiencing TAF failures for TOAD client. TOAD client session simply disconnects rather than failing over to the next node, It is noticed that TAF succesfully works for SQL client from the same client machine. Please support in resolving this issue, attached herewith are following from both nodes :

1) Listener file node1, node2
2) TNS file node1, node2
3) TNS file client
4) Output of show parameter listener from node1, node2
5) Output of lsnrctl services node1, node2

Summary of environment :

OS - Windows 2003 entp edition sp2, 32 bit
Database server - 10.2.0.5.0

Please let me know if there is any information more i can provide with.


Thank you
Ali
  • Attachment: all_files.txt
    (Size: 11.05KB, Downloaded 713 times)
Re: oracle 10g TAF fails for TOAD [message #526100 is a reply to message #526098] Sat, 08 October 2011 04:03 Go to previous messageGo to next message
John Watson
Messages: 8348
Registered: January 2010
Location: Global Village
Senior Member
I don't use TOAD, do you know if it is linked with the correct version of OCI that is needed for TAF? If it is, it should work. If it isn't, it won't.
If you have a number of clients, it is better to define the TAF characteristics of a service within the fdata dictionary, using DBMS_SERVICE, rather than in many tnsnames.ora files. Look up the package in the docs, it is very easy to use.

But I have to say that setting up a 10g RAC now is a bit silly. I can understand that you might have to use a 10g database, but you should be running RAC and ASM 11.2, installed with Grid Infrastructure. It is far more reliable, and still fully supported (unlike 10g).

[Added: in case I wasn't clear, what I am saying is that you should run your 10g database on 11g infrastructure]

[Updated on: Sat, 08 October 2011 06:02]

Report message to a moderator

Re: oracle 10g TAF fails for TOAD [message #528206 is a reply to message #526100] Sun, 23 October 2011 02:05 Go to previous message
mmaz2002
Messages: 11
Registered: October 2011
Location: India
Junior Member
Hi John,

Thanks for the useful tip, I installed 10g client on the 64 bit windows 7 machine (client PC) as my previous client was 9i. But after doing so, i ended up experiencing issues with errors in initializing OCI and following are the changes i made to overcome the issue :

1) control panel > Administrative Tools > Local Security Policy > User Rights Assignment > Create Global Objects > Add Windows user here and Apply.

Now TAF works fine with me

I was also facing issues with SQL client after installing 10g client, SQL client was closing immediately after inserting credentials at the prompt. To overcome this issue i started SQL client by right clicking on the SQL client and running it as ADMIN.

Hope this information is of help to someone.


Thank you.
Ali
Previous Topic: CRS is not starting
Next Topic: Sap Backups On rac Environment
Goto Forum:
  


Current Time: Sun Sep 27 19:18:40 CDT 2020