Home » Server Options » RAC & Failsafe » RAC failed during running root.sh in second node (Redhat x86_64, Oracle 10g(10.2))
RAC failed during running root.sh in second node [message #523383] Sat, 17 September 2011 08:35 Go to next message
NAJU
Messages: 6
Registered: April 2011
Location: Kabul
Junior Member

Please help to resolve below issue.


when running the root.sh on second node the following error occured

adding daemons to inittab
expecting the crs daemons to be up within 600 seconds

failure at final check of oracle CRS stack. 10



please update ,, what areas to rectify
Re: RAC failed during running root.sh in second node [message #523386 is a reply to message #523383] Sat, 17 September 2011 09:02 Go to previous messageGo to next message
BlackSwan
Messages: 26733
Registered: January 2009
Location: SoCal
Senior Member
ensure that cluvfy runs successfully on second node
Re: RAC failed during running root.sh in second node [message #523393 is a reply to message #523386] Sat, 17 September 2011 10:35 Go to previous messageGo to next message
NAJU
Messages: 6
Registered: April 2011
Location: Kabul
Junior Member

./runcluvy stage -pre crsinst -n DBNODE2 -verbose --------results


ERROR:

could not find a suitable set of interfaces for VIPs


i have assigned the VIPs in /etc/hosts

172.16.2.45 DBNODE2-vip.world DBNODE2-vip DBNODE2.world


please reply ,,,, urgent issue


Re: RAC failed during running root.sh in second node [message #523394 is a reply to message #523393] Sat, 17 September 2011 10:54 Go to previous messageGo to next message
BlackSwan
Messages: 26733
Registered: January 2009
Location: SoCal
Senior Member
It would be helpful if you followed Posting Guidelines - http://www.orafaq.com/forum/t/88153/0/

>please reply ,,,, urgent issue
please explain why it is urgent for me to solve this issue for you.
Re: RAC failed during running root.sh in second node [message #523397 is a reply to message #523394] Sat, 17 September 2011 12:19 Go to previous messageGo to next message
NAJU
Messages: 6
Registered: April 2011
Location: Kabul
Junior Member

i am sorry for being rude,

i would really use your expertise on this issue.

we were running our system on single instance so due to overload we need to put the balancing.

i am getting this issue.

everything is going well except when i run root.sh in second node

the below error is coming.

adding daemons to inittab
expecting the crs daemons to be up within 600 seconds

failure at final check of oracle CRS stack.


i have checked below log files in DBNODE2


/CRS/log/alertDBNODE2.log

cssd(11063) CRS-1605:cssd voting file is online: /dev/raw/raw2. details in /u01/app/oracle/CRS/log/dbnode2/cssd/ocssd.log




ocssd.log


dump grock state db
end of grock state dump
end dump


ocrsd.log


clsc_connect: no listener at (Address=(protocol=ipc)(key=OCSDD_LL_dbnode2_crs))

clsssinitnative: connect failed, rc 9

ocss is not ready. received status 3 from css. waiting for good status

panic OCRSD exiting: could not init the css context

terminating clsd session



please i dont know what is actual issue.

thanks in advance
Re: RAC failed during running root.sh in second node [message #523406 is a reply to message #523397] Sat, 17 September 2011 14:24 Go to previous messageGo to next message
John Watson
Messages: 8348
Registered: January 2010
Location: Global Village
Senior Member
Hi - one thing that may help you is that this "error"
Quote:
ERROR:

could not find a suitable set of interfaces for VIPs

is not a critical error. Addresses 172.16.x.x are not routable, and VIPs are supposed to be routable. This doesn't actually matter, but the 10g OUI/cluvfy/root.sh can't handle it: you have to run the vipca utility manually after the root.sh has finished. So this is not the problem.

From my own experience, I would say that almost certainly you have a problem with the shared storage. Check it again, and again, and again.
Re: RAC failed during running root.sh in second node [message #523419 is a reply to message #523406] Sun, 18 September 2011 04:54 Go to previous messageGo to next message
NAJU
Messages: 6
Registered: April 2011
Location: Kabul
Junior Member

THANKS FOR THE REPLY,

please find below information of my setup.

SERVER DETAIL

DELL POWEREDGE 2900

REDHAT 4 ES

MY PARTITION DETAILS

/DEV/SDA1
/DEV/SDA2
/DEV/SDA3
/DEV/SDA4
/DEV/SDA5

THE INSTALLATION OF REDHAT IS THROUGH POWEREDGE CD AND THE PARTITION IS CONFIGURED THROUGH LVM.


ORACLEASM IS INSTALLED ON LVM LOGICAL PARTITION SUCCESSFULLY

STATUS IS OK FOR DISK.

THEN I INSTALLED RAW DEVICES ON LOGICAL PARTITION FOR OCR AND VOTING DISK


AND MAPPED UNDER

/ETC/SYSCONFIG/RAWDEVICES

/DEV/RAW/RAW1 /DEV/VOLGROUP_ID_13399/LogVol5

/DEV/RAW/RAW2 /DEV/VOLGROUP_ID_13399/LogVol7


restarted services

service rawdevices restart


then changed the ownership


chown root:oinstall /dev/raw/raw1
chown oradb:oinstall /dev/raw/raw2
chmod 640 /dev/raw/raw1
chmod 660 /dev/raw/raw2
below logical partitions are not mapped anywhere.

/dev/Volgroup_id_13399/LogVol5
/dev/Volgroup_id_13399/LogVol7


then i have installed ocvuqdisk rpm but is there any configuration needed or no ?


please let me know how to solve the issue ?



Re: RAC failed during running root.sh in second node [message #523420 is a reply to message #523419] Sun, 18 September 2011 04:56 Go to previous messageGo to next message
NAJU
Messages: 6
Registered: April 2011
Location: Kabul
Junior Member

when i run hwos cvutility check then the message is coming along with VIPs error

unable to find sharedness of /dev/sda for DBNODE1,DBNODE2
Re: RAC failed during running root.sh in second node [message #523422 is a reply to message #523420] Sun, 18 September 2011 08:30 Go to previous message
NAJU
Messages: 6
Registered: April 2011
Location: Kabul
Junior Member

VIPCA error after root.sh failure in node 2


unable to communicate with CRS services
Previous Topic: SCAN IP for oracle RAC 11g R2
Next Topic: RMAN Duplicate taking long to finish.
Goto Forum:
  


Current Time: Sun Sep 27 19:15:16 CDT 2020