Home » Developer & Programmer » Reports & Discoverer » Text Field Not Wrapping Properly (Oracle Developer Suite 10, Unix)
Text Field Not Wrapping Properly [message #521759] Thu, 01 September 2011 18:02 Go to next message
TX_developer
Messages: 46
Registered: July 2011
Member
I have a text field on my layout with 3 lines of text and plenty of space before the end of the text box. When I run the report the second line is shortened and the last two words are moved to the third line. Because I have a carriage return behind those two words, this then moves the original third line to the fourth line. Why does Oracle Reports do this when there is plenty of room and it looks fine in the layout?
Re: Text Field Not Wrapping Properly [message #521803 is a reply to message #521759] Fri, 02 September 2011 03:57 Go to previous messageGo to next message
cookiemonster
Messages: 13864
Registered: September 2008
Location: Rainy Manchester
Senior Member
Font mapping most likely. The appserver is using different fonts to your PC.
Re: Text Field Not Wrapping Properly [message #521853 is a reply to message #521803] Fri, 02 September 2011 07:22 Go to previous messageGo to next message
TX_developer
Messages: 46
Registered: July 2011
Member
We use a Courier font on this report. Shouldn't that be the same on the appserver?
Re: Text Field Not Wrapping Properly [message #521854 is a reply to message #521853] Fri, 02 September 2011 07:30 Go to previous messageGo to next message
cookiemonster
Messages: 13864
Registered: September 2008
Location: Rainy Manchester
Senior Member
You would have thought so but I'd double check.
Does the problem happen when you run the report locally?
Re: Text Field Not Wrapping Properly [message #521855 is a reply to message #521854] Fri, 02 September 2011 07:43 Go to previous messageGo to next message
TX_developer
Messages: 46
Registered: July 2011
Member
I run it from the Oracle Developer, however, I don't have it installed locally. I run the developer through Citrix. It does however behave differently when the users run it then when I run it. Very frustrating for me.
Re: Text Field Not Wrapping Properly [message #521860 is a reply to message #521855] Fri, 02 September 2011 08:03 Go to previous message
cookiemonster
Messages: 13864
Registered: September 2008
Location: Rainy Manchester
Senior Member
Then it definitely sounds like server settings are coming into play somewhere.
Unfortunately I'm not an expert in that area. Try printing out their copy and yours and overlay them - that should make any font differences immediately obvious.
Previous Topic: Getting stuck in the use of placholder and before report trigger
Next Topic: Generate report to database table
Goto Forum:
  


Current Time: Tue Mar 31 06:08:45 CDT 2020