Home » Developer & Programmer » Data Integration » Error Installing Oracle Work Flow server (Oracle 11gR1, Windows XP)
Error Installing Oracle Work Flow server [message #449264] Mon, 29 March 2010 00:12 Go to next message
dadorado
Messages: 2
Registered: March 2010
Location: PH
Junior Member
I need help badly. I was trying to install Oracle Workflow Server 2.6.4 to one of my databases locally. I tried running the script from the location D:\oracle\product\11.1.0\db_1\owb\wf\install\wfinstall.bat and the details that I've inputted are the following:

Workflow Account: owfmgr
Workflow Password: owfmgr
SYS password: sys
TNS Connect Descriptor: hipposerver:1521:CD221MLA

However after submitting the details I got the following error:

Workflow Configuration Assistant 2.6.4.0.0 - Windows XP
WFCA Version: : WorkflowCA.java 26.106 2005/06/29 04:33
WorkflowCA: 
WorkflowCA: Workflow Configuration in progress...
WorkflowCA: Mon Mar 29 12:45:07 SGT 2010
WorkflowCA: 
WorkflowCA: Screen width -1280-, screen height -1024-
WorkflowCA: 
WorkflowCA: Graphics User Interface mode
WorkflowCA: 
WorkflowCA: 
WorkflowCA: Start testing connection, which takes less than 3 minutes.
WorkflowCA: 
WorkflowCA: Account connection test for  SYS
WorkflowCA: [SYS] ORA-00604: error occurred at recursive SQL level 1
ORA-12705: Cannot access NLS data files or invalid environment specified

WorkflowCA: Unable to connect to jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=hipposerver)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=CD221MLA)))
java.lang.Exception: Invalid connection
	at oracle.apps.fnd.wf.install.db.WorkflowCA.createJDBCConnection(WorkflowCA.java:4812)
	at oracle.apps.fnd.wf.install.db.WorkflowCA.createSYSConnection(WorkflowCA.java:4908)
	at oracle.apps.fnd.wf.install.db.WorkflowCA.schemaCreation(WorkflowCA.java:1039)
	at oracle.apps.fnd.wf.install.db.WfFrame.actionPerformed(WfFrame.java:2051)
	at oracle.ewt.button.PushButton.processActionEvent(Unknown Source)
	at oracle.ewt.lwAWT.LWButton.processActionEvent(Unknown Source)
	at oracle.ewt.button.PushButton.processEventImpl(Unknown Source)
	at oracle.ewt.lwAWT.LWComponent.redispatchEvent(Unknown Source)
	at oracle.ewt.lwAWT.LWComponent.processEvent(Unknown Source)
	at oracle.ewt.button.PushButton.activate(Unknown Source)
	at oracle.ewt.lwAWT.AbstractButton.processMouseReleased(Unknown Source)
	at oracle.ewt.lwAWT.AbstractButton.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Component.java:5266)
	at java.awt.Container.processEvent(Container.java:1966)
	at oracle.ewt.lwAWT.LWComponent.processEventImpl(Unknown Source)
	at oracle.ewt.button.PushButton.processEventImpl(Unknown Source)
	at oracle.ewt.lwAWT.LWComponent.redispatchEvent(Unknown Source)
	at oracle.ewt.lwAWT.LWComponent.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Component.java:3968)
	at java.awt.Container.dispatchEventImpl(Container.java:2024)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3892)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
	at java.awt.Container.dispatchEventImpl(Container.java:2010)
	at java.awt.Window.dispatchEventImpl(Window.java:1778)
	at java.awt.Component.dispatchEvent(Component.java:3803)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
WorkflowCA: Mon Mar 29 12:45:38 SGT 2010
WorkflowCA: java.lang.Exception: Invalid connection (0)
WorkflowCA: Terminating...


The connection details are correct since it was just copied from my tnsnames.ora file soI googled error ORA-12705 and it came up with a lot of solutions. I checked NLS_LANG of my database

SQL on CD221MLA> select DECODE(parameter, 'NLS_CHARACTERSET', 'CHARACTER SET',
  2  'NLS_LANGUAGE', 'LANGUAGE',
  3  'NLS_TERRITORY', 'TERRITORY') name,
  4  value from v$nls_parameters
  5  WHERE parameter IN ( 'NLS_CHARACTERSET', 'NLS_LANGUAGE', 'NLS_TERRITORY')
  6  /

NAME          VALUE
------------- ----------------------------------------------------------------
LANGUAGE      AMERICAN
TERRITORY     AMERICA
CHARACTER SET UTF8


I also checked the registry and the NLS_LANG parameter was set to AMERICAN_AMERICA.UTF8. I tried removing this from the registry restarted the database and tried installing workflow but it still returns the same error. I reveted the changes to my registry again and restarted the machine it still returns the same error. Please help!
Re: Error Installing Oracle Work Flow server [message #449267 is a reply to message #449264] Mon, 29 March 2010 00:25 Go to previous message
dadorado
Messages: 2
Registered: March 2010
Location: PH
Junior Member
I also tried the solution posted on MOS Document 351873.1 (Getting Up To Speed on Workflow 2.6.4) but it still returning the same error. Need help guys.
Previous Topic: OWB Connectivity problem with "User Defined" Activity...
Next Topic: OWB-Filtering on a dimension table
Goto Forum:
  


Current Time: Thu May 28 03:45:59 CDT 2020