Home » RDBMS Server » Server Utilities » ORA 39000 | ORA 39142 (Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production)
ORA 39000 | ORA 39142 [message #677747] Fri, 11 October 2019 00:57 Go to next message
vippysharma
Messages: 46
Registered: May 2013
Location: New Delhi
Member
I have dump file exported (using expdp) from oracle DB (Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production) and while importing the same dump file in new DB in separate m/c (Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production) using impdp, getting Ora-39000 & Ora-39142 error. (bad dump file | Incompatible version)
Attached is the Dump file info screenshot (Dump_info.jpg) using show_dump_file_info proc...

Both the source and target database is having same version and not sure why i am getting this error. Analysis said to do fresh export using VERSION parameter. Is there any other way to import without re-executing export?

  • Attachment: Dump_Info.JPG
    (Size: 28.65KB, Downloaded 205 times)
Re: ORA 39000 | ORA 39142 [message #677748 is a reply to message #677747] Fri, 11 October 2019 01:09 Go to previous messageGo to next message
Michel Cadot
Messages: 66728
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

ORA-39000: bad dump file specification
 *Cause:  The user specified a dump file that could not be used in the
          current job.  Subsequent error messages describe the inadequacies
          of the dump file.
 *Action: Specify a dump file that is usable for the job.
ORA-39142: incompatible version number %s in dump file \"%s\"
 *Cause:  A dump file was specified for an import operation whose version
          number is incompatible with the dump file version of the
          Data Pump product currently running on the system. Usually this
          message indicates that the dump file was produced by a newer
          version of the Data Pump export utility.
 *Action: Import this dump file using the Data Pump import utility with
          the same version as the export which created the file.
Re: ORA 39000 | ORA 39142 [message #677750 is a reply to message #677748] Fri, 11 October 2019 01:41 Go to previous messageGo to next message
vippysharma
Messages: 46
Registered: May 2013
Location: New Delhi
Member
Quote:
*Action: Import this dump file using the Data Pump import utility with
the same version as the export which created the file.
--Already executed this but same error
impdp user/pwd@SID full=y dumpfile=file.dmp logfile=Imp.log directory=Mydir version=12.1.01.0 
Re: ORA 39000 | ORA 39142 [message #677751 is a reply to message #677747] Fri, 11 October 2019 01:46 Go to previous messageGo to next message
John Watson
Messages: 8085
Registered: January 2010
Location: Global Village
Senior Member
When you say that the two databases are the same version, you need to be sure that they also have the same RU applied. For example, if the source has the July 2019 RU and the destination is on the April RU, you may get this error.
Re: ORA 39000 | ORA 39142 [message #677752 is a reply to message #677751] Fri, 11 October 2019 02:19 Go to previous message
vippysharma
Messages: 46
Registered: May 2013
Location: New Delhi
Member
Quote:
For example, if the source has the July 2019 RU and the destination is on the April RU, you may get this error.
okay, will check this...thank you
Previous Topic: oracle solution for sqoop
Next Topic: Schema export with parallel parameter
Goto Forum:
  


Current Time: Sat Dec 14 07:23:41 CST 2019