Home » Developer & Programmer » Forms » set_menu_item_property error in 12c - FRM41068
set_menu_item_property error in 12c - FRM41068 [message #668269] Thu, 15 February 2018 22:06 Go to next message
malu
Messages: 14
Registered: December 2017
Junior Member
Hello ,

I need a help . we are doing forms migration from 11g to 12c.
But while the running the form set_menu_item_property in mmb file s giving error- FRM41068.

Any one please suggest what need to checked.

Thanks,
Malu
Re: set_menu_item_property error in 12c - FRM41068 [message #668270 is a reply to message #668269] Thu, 15 February 2018 22:22 Go to previous messageGo to next message
BlackSwan
Messages: 26649
Registered: January 2009
Location: SoCal
Senior Member
malu wrote on Thu, 15 February 2018 20:06
Hello ,

I need a help . we are doing forms migration from 11g to 12c.
But while the running the form set_menu_item_property in mmb file s giving error- FRM41068.

Any one please suggest what need to checked.

Thanks,
Malu
http://lmgtfy.com/?q=FRM-41068
Re: set_menu_item_property error in 12c - FRM41068 [message #668271 is a reply to message #668270] Thu, 15 February 2018 22:27 Go to previous messageGo to next message
malu
Messages: 14
Registered: December 2017
Junior Member
I checked the item is visible or not before setting property.
Re: set_menu_item_property error in 12c - FRM41068 [message #668274 is a reply to message #668271] Fri, 16 February 2018 03:25 Go to previous messageGo to next message
malu
Messages: 14
Registered: December 2017
Junior Member
Can anyone help please.
Re: set_menu_item_property error in 12c - FRM41068 [message #668310 is a reply to message #668274] Sat, 17 February 2018 12:02 Go to previous messageGo to next message
Littlefoot
Messages: 21530
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Try to set NLS_LANG to UTF-8 in both registry and default.env file, such as
NLS_LANG=AMERICAN_AMERICA.UTF8
and add SYNCHRONIZE before and after calling the SET_MENU_ITEM_PROPERTY, such as
synchronize;
set_menu_item_property ...
synchronize;
Re: set_menu_item_property error in 12c - FRM41068 [message #668327 is a reply to message #668310] Sun, 18 February 2018 23:41 Go to previous messageGo to next message
malu
Messages: 14
Registered: December 2017
Junior Member
i tried synchronize . it is working .
but the problem is we are setting the menu labels inside loop;
so if i set synchronize before and after , it is giving performance issue.

NLS_LANG=AMERICAN_AMERICA.UTF8 - > this is already set

I think when we hard code the value , it is working ;

can anyone please tell why exactly this is happening .
Re: set_menu_item_property error in 12c - FRM41068 [message #668336 is a reply to message #668327] Mon, 19 February 2018 02:37 Go to previous messageGo to next message
Littlefoot
Messages: 21530
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
So, put SYNCHRONIZE in front and behind the loop. Would that help?

Why this is happening? As far as I can tell, Oracle bug.
Re: set_menu_item_property error in 12c - FRM41068 [message #668338 is a reply to message #668336] Mon, 19 February 2018 02:48 Go to previous messageGo to next message
malu
Messages: 14
Registered: December 2017
Junior Member
ya put SYNCHRONIZE in front solved issue .
but it hitting performance .
Re: set_menu_item_property error in 12c - FRM41068 [message #668340 is a reply to message #668338] Mon, 19 February 2018 03:02 Go to previous messageGo to next message
Littlefoot
Messages: 21530
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
So badly?

Just to make things clear: this affects performance? I guess it shouldn't (though, I just hope it fixes the issue you have):
synchronize;
loop
  ...
  set_menu_item_property ...
  ...
end loop;
synchronize;

Or did you use
loop
  ...
  synchronize;
  set_menu_item_property ...
  synchronize;
  ...
end loop;

[Updated on: Mon, 19 February 2018 03:22]

Report message to a moderator

Re: set_menu_item_property error in 12c - FRM41068 [message #668342 is a reply to message #668340] Mon, 19 February 2018 03:12 Go to previous messageGo to next message
malu
Messages: 14
Registered: December 2017
Junior Member
kept inside loop before set_menu_item_property ...
loop
synchronize
set_menu_item_property ...
...
end loop;
Re: set_menu_item_property error in 12c - FRM41068 [message #668343 is a reply to message #668342] Mon, 19 February 2018 03:23 Go to previous messageGo to next message
Littlefoot
Messages: 21530
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
That's why I said - move it out of the loop (the way I showed in my 1st example in message #668340). If it works, fine - and it won't affect performance.
Re: set_menu_item_property error in 12c - FRM41068 [message #668544 is a reply to message #668269] Wed, 28 February 2018 13:14 Go to previous messageGo to next message
iamorangehat
Messages: 3
Registered: August 2010
Location: Findlay, Ohio
Junior Member
You still having the issue?
Re: set_menu_item_property error in 12c - FRM41068 [message #668703 is a reply to message #668544] Mon, 12 March 2018 00:54 Go to previous messageGo to next message
malu
Messages: 14
Registered: December 2017
Junior Member
Hello ,
when i kept synchronize outside loop it was still creating problems.
if it is inside loop , it works but little performance down .
Thanks for you great help.
Regards,
Malu

Re: set_menu_item_property error in 12c - FRM41068 [message #668715 is a reply to message #668703] Mon, 12 March 2018 07:22 Go to previous messageGo to next message
iamorangehat
Messages: 3
Registered: August 2010
Location: Findlay, Ohio
Junior Member
I was never able to get the synchronize to work, still got the error.
"Message" eliminated it but who the heck want to click on a message every time in the loop.

I was able to eliminate the error by throwing a dbms_output.put_line in front of the set_menu_item_property line.
Might be a stupid idea but it fixed the error.

dbms_output.disable;
<< then in my for x1 loop >>
dbms_output.put_line (x1.application_id || ' ' || x1.application_desc);
set_menu_item_property('SUB_MENU.SM' || ltrim(to_char(ctr,'09')), LABEL, x1.application_id || ' ' || x1.application_desc);
Re: set_menu_item_property error in 12c - FRM41068 [message #668725 is a reply to message #668715] Mon, 12 March 2018 12:47 Go to previous messageGo to next message
joy_division
Messages: 4949
Registered: February 2005
Location: East Coast USA
Senior Member
iamorangehat wrote on Mon, 12 March 2018 08:22
I was never able to get the synchronize to work, still got the error.
"Message" eliminated it but who the heck want to click on a message every time in the loop.

I was able to eliminate the error by throwing a dbms_output.put_line in front of the set_menu_item_property line.
Might be a stupid idea but it fixed the error.

dbms_output.disable;
<< then in my for x1 loop >>
dbms_output.put_line (x1.application_id || ' ' || x1.application_desc);
set_menu_item_property('SUB_MENU.SM' || ltrim(to_char(ctr,'09')), LABEL, x1.application_id || ' ' || x1.application_desc);
I am sorry, I do not believe you. DBMS_OUTPUT will not work in Forms, or more precisely, you cannot see any output from it.

[Updated on: Tue, 13 March 2018 14:03]

Report message to a moderator

Re: set_menu_item_property error in 12c - FRM41068 [message #668731 is a reply to message #668725] Mon, 12 March 2018 23:14 Go to previous messageGo to next message
malu
Messages: 14
Registered: December 2017
Junior Member
Hello,
Its not a bad idea .We can put a form message with no_acknowledge inside loop instead of DBMS_OUTPUT ; it works Smile
Regards,
Malu
Re: set_menu_item_property error in 12c - FRM41068 [message #668820 is a reply to message #668725] Thu, 15 March 2018 09:04 Go to previous message
iamorangehat
Messages: 3
Registered: August 2010
Location: Findlay, Ohio
Junior Member
You are correct.
I don't want any output.
I just want the set command to work and it works now.

[Updated on: Thu, 15 March 2018 09:07]

Report message to a moderator

Previous Topic: Pick session IP address in Web mode
Next Topic: *newbie* please help!
Goto Forum:
  


Current Time: Tue Jan 28 04:30:38 CST 2020