Home » Developer & Programmer » Reports & Discoverer » Arabic Language not show in oracle reports 11G (Oracle Reports)
Arabic Language not show in oracle reports 11G [message #615210] Sat, 31 May 2014 15:55 Go to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
Hi ,

i create Report using Oracle Report 11g

But Text wright with Arabic language not show

what can i do to see Arabic lang. in oracle reports

Kindly find attached for my report
Re: Arabic Language not show in oracle reports 11G [message #615217 is a reply to message #615210] Sun, 01 June 2014 01:54 Go to previous messageGo to next message
ranamirfan
Messages: 534
Registered: January 2006
Location: Pakistan / Saudi Arabia
Senior Member

Dear,
Please have a look http://www.orafaq.com/forum/mv/msg/179127/544928/#msg_544928.

Regards,
Irfan
Re: Arabic Language not show in oracle reports 11G [message #615234 is a reply to message #615210] Sun, 01 June 2014 04:34 Go to previous messageGo to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
Thanks for your replay ....

But my problem not Report character Arrangement

but my problem i see Arabic character as a Unexplained Codes

Thanks
Re: Arabic Language not show in oracle reports 11G [message #615237 is a reply to message #615234] Sun, 01 June 2014 05:30 Go to previous messageGo to next message
ranamirfan
Messages: 534
Registered: January 2006
Location: Pakistan / Saudi Arabia
Senior Member

Did you try this.?
Re: Arabic Language not show in oracle reports 11G [message #615241 is a reply to message #615237] Sun, 01 June 2014 06:08 Go to previous messageGo to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
yes
Re: Arabic Language not show in oracle reports 11G [message #615242 is a reply to message #615241] Sun, 01 June 2014 06:10 Go to previous messageGo to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
Can you Help me with teamviewer (remote access my PC)
Because of my failure to solve it
Re: Arabic Language not show in oracle reports 11G [message #615249 is a reply to message #615242] Sun, 01 June 2014 07:41 Go to previous messageGo to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
can anybody help me ?
Re: Arabic Language not show in oracle reports 11G [message #615259 is a reply to message #615249] Sun, 01 June 2014 09:02 Go to previous messageGo to next message
ranamirfan
Messages: 534
Registered: January 2006
Location: Pakistan / Saudi Arabia
Senior Member

Dear,
Did you also Set Registry Value_Name :- NLS_LANG ,Value_Data :- AMERICAN_AMERICA.AR8MSWIN1256 ?

Regards,
Irfan
Re: Arabic Language not show in oracle reports 11G [message #615285 is a reply to message #615210] Sun, 01 June 2014 11:54 Go to previous messageGo to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
yes it try

AMERICAN_AMERICA.AR8MSWIN1256

and

arabic_egypt.ar8mswin1256

the problem still exists Sad
Oracle Reports Arabic Language [message #615288 is a reply to message #615210] Sun, 01 June 2014 12:10 Go to previous messageGo to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
Please in oracle reports character wright with arabic Language

see like åÇäì ÑÇÝÊ åÇäì ÑÇÝÊ

please urgent can any one help me using teamviewer (Remote access)

https://www.teamviewer.com/

my ID : 393 030 444

Password : 3560

Re: Arabic Language not show in oracle reports 11G [message #615300 is a reply to message #615234] Mon, 02 June 2014 00:09 Go to previous messageGo to next message
Littlefoot
Messages: 21517
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
hany1002 wrote on Sun, 01 June 2014 11:34

but my problem i see Arabic character as a Unexplained Codes


I don't have any experience regarding multilingual environment (moreover, I can not read Arabic, but - comparing output you get and the .JPG file name - I see the difference and understand your question).

Are you sure that these values are correctly stored into the database? Because, if you put garbage in, you'll get garbage out.
Re: Arabic Language not show in oracle reports 11G [message #615426 is a reply to message #615300] Tue, 03 June 2014 17:01 Go to previous messageGo to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
i find the solution Very Happy

add uifont.ali paths to following Register keys > TK & UI
Re: Arabic Language not show in oracle reports 11G [message #615562 is a reply to message #615426] Thu, 05 June 2014 07:53 Go to previous messageGo to next message
mazhar.ehsan
Messages: 2
Registered: June 2014
Location: Saudi Arabia
Junior Member
hany1002 wrote on Tue, 03 June 2014 17:01
i find the solution Very Happy

add uifont.ali paths to following Register keys > TK & UI


Hi all,
I have the same issue (junk character in the PDF for Arabic information in the reports) with Report Builder 10.1.2.0.2 (10g) on my Windows 7 machine but could not solve it. Even though , the registry for the TK & UI is already set properly.

I have done and checked everything including the steps in the URL http://www.orafaq.com/forum/t/162197/

Nothing could fix the problem upto now.

Will appreciate any feedback or useful input on the issue.

Thanks in advance,
Re: Arabic Language not show in oracle reports 11G [message #615629 is a reply to message #615562] Fri, 06 June 2014 04:11 Go to previous messageGo to next message
hany1002
Messages: 10
Registered: May 2014
Location: Egypt
Junior Member
first we'll found uifont.ali for OFM at this paths:

Middleware_Home\asinst_1\config\FRComponent\frcommon\tools\COMMON
Middleware_Home\asinst_1\config\FRComponent\frcommon\guicommon\tk\admin
Middleware_Home\as_1\frcommon\templates\tk\config

change exist file to attached file and install attached font to windows fonts if it not installed
change your NLS_LANG to Arabic Lang " u know how to do that"
add fonts path to following Register keys > FORMS_PATH & REPORT_PATH if u don't found it there
add uifont.ali paths to following Register keys > ed]TK & UI

but this link in TK and UI


Middleware_Home\asinst_1\config\FRComponent\frcommon\tools\COMMON


Restart your Application Server
then change your report font to one of following fonts
Arabic Transparent
Simplified Arabic
Traditional Arabic
Courier New
Arial
and test your report then see what's will happen
Regards
Hany Raafat
Re: Arabic Language not show in oracle reports 11G [message #615699 is a reply to message #615629] Sat, 07 June 2014 07:26 Go to previous messageGo to next message
mazhar.ehsan
Messages: 2
Registered: June 2014
Location: Saudi Arabia
Junior Member
Hi Hany Raafat,
Thanks for your reply but all of these steps did not solve my problem.

I tried with the file 'unifont.uni' and also installed the font downloaded from the site http://www.araboug.org/ib/index.php?showtopic=48493
yet did not succeed in generating the correct PDF file.

Surprisingly, I get the below error from the report server with the 'unifont.uni' downloaded from your site

REP-1924: Cannot locate the font file 'COUR.TTF'

The above error does not occur if I use my existing 'unifont.uni'. Yet it gives garbage characters in the PDF file for the arabic data.


Please note, a couple of months back I used to take the following workaround for this problem. But now, even this is not working

1. Stop the local Oc4JInstance
2. Start the local report sever by running from the command line: rwserver SERVER=<MyReportServer>.
3. Run the report : http://localhost:8889/reports/rwservlet?report=testrep.rdf&userid=user/password@database&destype=cache&desformat=pdf

Could anyone help?

Now I am planning to work on an upgrade project from Application Server 10g + Developer 10g to WebLogic Server + Developer 11g. I wonder what will be the status of this issue in the proposed version.

Sincerely,
Maz

[Updated on: Sat, 07 June 2014 08:07]

Report message to a moderator

Re: Arabic Language not show in oracle reports 11G [message #670022 is a reply to message #615210] Wed, 30 May 2018 02:16 Go to previous messageGo to next message
SUNEER
Messages: 1
Registered: May 2018
Junior Member
set NLS_LANGUAGE in the registry to AMERICAN_AMERICA.AR8MSWIN1256
Add Arabic language with existing language in Regional Settings
Re: Arabic Language not show in oracle reports 11G [message #674456 is a reply to message #615629] Mon, 28 January 2019 02:30 Go to previous message
checks
Messages: 4
Registered: January 2007
Junior Member
Configuration given by Hany works. I have tried. Attached the uifonts.ali which works. Change the extension to .ali and save it.



[Edit MC: remove uifont.ali file which is Oracle copyrighted.
If you have some customization about this file answering the current problem then post only the modified lines]
See the following references about uifont.ali file:
https://docs.oracle.com/cd/E14571_01/bi.1111/b32121/pbr_font003.htm#i1009745
https://support.oracle.com/knowledge/Middleware/2091306_1.html
https://it.toolbox.com/question/arabic-font-issue-with-pdf-report-121913
http://www.araboug.org/ib/index.php?showtopic=21965


[Updated on: Mon, 28 January 2019 03:13] by Moderator

Report message to a moderator

Previous Topic: REP-51002: Bind to Reports Server bb failed.
Next Topic: ORA-24323 Value not allowed in the Report Builder
Goto Forum:
  


Current Time: Sun Dec 08 17:53:14 CST 2019