Home » Developer & Programmer » JDeveloper, Java & XML » insertion of xml data to clob/xmltpe (oracle11R2,Linux)
insertion of xml data to clob/xmltpe [message #654955] Wed, 17 August 2016 07:28 Go to previous message
prejib
Messages: 126
Registered: March 2009
Location: India
Senior Member
Hi,

We have a table with the below structure .
SQL> desc example1
 Name                                      Null?    Type
 ----------------------------------------- -------- ----------------------------
 KEY_COLUMN                                         VARCHAR2(10)
 XML_COLUMN                                         PUBLIC.XMLTYPE
while trying to insert data to the table having length(XML_COLUMN) <=4000 is allowed through the insert script and is successfull. But when I tried the insert data with length(XML_COLUMN) > 4000 , the script is failing with the below error . The same thing is happening for 'clob' column also . scripts are given in the attached file . I tried the same by running the .sql file also .
SQL> @TEST
'<?xml version="1.0"?>
*
ERROR at line 5:
ORA-01704: string literal too long

But when I tried to load data from the .xml file , I am able to do that by putting in a directory . But I want to do this activity in insert script only . Can you any one please help me .
Thanks
Prejib
  • Attachment: test.sql
    (Size: 315.88KB, Downloaded 881 times)
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Dynamic splitting of column
Next Topic: JDeveloper ADF Clear Form Fields
Goto Forum:
  


Current Time: Wed Nov 25 05:09:06 CST 2020