Home » Developer & Programmer » Forms » Oracle Forms 6i and Patch 19 (Windows 7 and Database 12.1.0.2)
Oracle Forms 6i and Patch 19 [message #677441] Fri, 20 September 2019 09:31 Go to next message
AMER_ALIDANDCHI
Messages: 2
Registered: September 2019
Junior Member
Hallo everyone,

I have questions according to the topic forms/reports 6i :

1) I want to install a clean version from Oracle Forms/Reports 6i with Patch 19 on Windows 7 32 bit without any problems and i want to connect with database 12.1.0.2 ,where can i find a clean version without problems , could you send me a link to download .Forms/Reports 6i with patch 19.

2) Is there any problems with Windows7 ,when yes, which configuration in Windows must i do, could you please in details for me explain.

3) Is there any Problems with database 12.1.0.2 , which configuration must i do on database .must i change UTF8 NLS_CHARACTER_SET or sqlnet.ora on database Server. (Database will be installed on Server and Forms 6i will be installed on Client Side separately).

4) After installation ,which Configuration must i do on Client side for Forms/Reports 6i for connection with database 12.1.0.2 , i mean adjustment for TNSNAMES.ORA and SQLNET.ORA on Client Side.

5) I do not want to deploy forms and reports on the Web , only Client/Server .(Desktop Application and not as Web Application ).I mean , i do not want to install Apllication Server.

Many thanks a lot in Advance.

Yours Sincerely.
AMER ALI DANDCHI

Re: Oracle Forms 6i and Patch 19 [message #677442 is a reply to message #677441] Fri, 20 September 2019 12:55 Go to previous messageGo to next message
John Watson
Messages: 8075
Registered: January 2010
Location: Global Village
Senior Member
Welcome to the forum. Please read the OraFAQ Forum Guide and How to use code tags and make your code easier to read

Your question is huge, and does show a lack of knowledge about how Oracle works: most importantly, you cannot legally get any patches unless you have a support contract. Furthermore, Forms 6i is way out of support, unless (I think) you have an EBS licence in which case it is still supported but only for use with EBS. With regard to operating systems, there is a support matrix that matches Oracle products to OS versions. You do not have to take it too seriously unless you intend to raise TARs with Support but I am sure that Forms 6 is not certified against Windows 7. THen there are the issues regarding connectivity between an old client (Forms 6i uses, if I remember correctly, OCI v8) and a newer server.

Perhas someone else can assist, but I think you need to describe your situation and the motivation for the questions in greater detail first.
Re: Oracle Forms 6i and Patch 19 [message #677443 is a reply to message #677442] Fri, 20 September 2019 13:20 Go to previous messageGo to next message
Michel Cadot
Messages: 66714
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Quote:
to raise TARs

H'm! SRs now (even for previous century products). Wink

Re: Oracle Forms 6i and Patch 19 [message #677444 is a reply to message #677443] Fri, 20 September 2019 14:04 Go to previous messageGo to next message
John Watson
Messages: 8075
Registered: January 2010
Location: Global Village
Senior Member
Some of my SRs have been open so long that they might as well have been TARs....
Re: Oracle Forms 6i and Patch 19 [message #677461 is a reply to message #677442] Sat, 21 September 2019 12:37 Go to previous messageGo to next message
AMER_ALIDANDCHI
Messages: 2
Registered: September 2019
Junior Member
At first thank you very much John Watson for your tips and for your answer.

I will try to describe the situation in details and to say for you the motivation.

The motivation is that we have a customer , who has many Applications, which were developed in Forms 6i with Oracle DB Version 12.1.0.2

and the customer does not want to upgrade to the newest Versions form Oracle for example Forms/Reports 12c and does not want to upgrade to the newest Version from Oracle DB and our Customer wants only extensions and improvement for these Applications and our Customer wants to keep Oracle Forms 6i and Oracle DB Version 12.1.0.2.

For this reason i want to install Forms/Reports 6i on Client Side at our Company with Compatibility with Oracle DB 12.1.0.2 (It was installed at our Company).

With regards to OS Version , there is no problem , i can install OS windows XP on Vitual Box or on my PC.

What i have read and noticed is the following:

Installing Patch Set 13 on Windows XP
Patch set 13 is certified for XP for the Builder and for Client/Server deployment.
To install patch set 13 on XP, a new version of Release 2 of 6i must first be
installed. This recut version of Release 2 fixes a problem with the Oracle installer
that prevents 6i to be installed on XP. The new version of Release 2 of 6i is
available on OTN.oracle.com.

Patch 19: This patch set has only been certified for use with Oracle
Applications installations and for Extended Maintenance Support
(EMS) customers. Standard Error Correction Support for non-Oracle
Applications users ended 31-JAN-2005. Please refer to Oracle
MetaLink Note:228666.1 for more details.

Supported Platforms in This Patch
The following platforms are supported in this patch:
■ AIX5L Based Systems (64-bit)
■ HP-UX PA-RISC (64-bit)
■ Linux x86 (32-bit)
■ Microsoft Windows (32-bit)
■ Solaris Operating System (SPARC)
For availability of Patch 19 on other platforms, please see Oracle MetaLink at
https://metalink.oracle.com/.

Server Licensing
If you want to deploy your Oracle Forms or Oracle Graphics to the Internet or an
intranet, then you need the Oracle Forms Server and its associated deployment
license.
The Oracle Forms Server is included on the general Oracle Forms Developer
CD-ROM for demonstration and test purposes, but is licensed separately. Contact
your Oracle sales representative to get additional information on Oracle Forms
Server pricing.Our customer does not want to deploy their Applications to the Internet or an Intranet by only desktop Applications (Client-Server(Oracle DB) Side).

What i need indeed from you a clean Version of Release 2 of Forms/Reports 6i and clean Copy from Patch 19/Patch 18/Patch 17 because of the compatibility Oracle DB 12.1.0.2 and i am for you very grateful.What i do , in addition to that i do my task and my job , in my opinion that i make research and development and i am ready constantly to exchange information and knowledge with you.

Many thanks fou you in advance for your help and effort.
Best Regards.
AMER ALI DANDCHI
Re: Oracle Forms 6i and Patch 19 [message #677463 is a reply to message #677461] Sun, 22 September 2019 01:49 Go to previous message
John Watson
Messages: 8075
Registered: January 2010
Location: Global Village
Senior Member
You have described exactly what I said: that Forms 6i is not supported, other than for old releases of EBS. If your client has an EBS licence which is still under support, you can use his CSI to download the patches.

Are you paying your Oracle partner fees? If so, you could go through your partner manager, they might be able to sort out something for you.

Otherwise, there is no legal way I can think of that you could obtain the software.
Previous Topic: navigable current Record
Next Topic: frm-40733
Goto Forum:
  


Current Time: Fri Dec 06 09:49:45 CST 2019