Home » Server Options » Data Guard » [DG Physical] ORA-00368: checksum error in redo log block (Oracle Solaris Sparc 64bit)
[DG Physical] ORA-00368: checksum error in redo log block [message #441353] Sun, 31 January 2010 00:14
Messages: 2
Registered: January 2010
Junior Member
Hi all,
I'm building a DR solution with 1 primary & 2 DR site (Physical).
All DBs use Oracle on Solaris 64bit.
The first one ran fine for some days (6), then I installed the 2nd. After restoring the DB (DUPLICATE TARGET DATABASE FOR STANDBY) & ready to apply redo. The DB fetched missing arc gaps & I got the following error:
Media Recovery Log /global/u04/recovery/billhcm/archive/2_32544_653998293.dbf
Errors with log /global/u04/recovery/billhcm/archive/2_32544_653998293.dbf
MRP0: Detected read corruption! Retry recovery once log is re-fetched...
Wed Jan 27 21:46:25 2010
Errors in file /u01/oracle/admin/billhcm/bdump/billhcm1_mrp0_12606.trc:
ORA-00368: checksum error in redo log block
ORA-00353: log corruption near block 1175553 change 8236247256146 time 01/27/2010 18:33:51
ORA-00334: archived log: '/global/u04/recovery/billhcm/archive/1_47258_653998293.dbf'
Managed Standby Recovery not using Real Time Apply
Recovery interrupted!
Recovered data files to a consistent state at change 8236247255373
I see that may be RFS get the file incorrectly so I ftp to get this file & continue the apply, it pass. Comparison of the RFS file & ftp is difference. At that time, I think that something wrong with the RFS because the content of arc is not right. (I used BACKUP VALIDATE ARCHIVELOG SEQUENCE BETWEEN n1 AND n2 THREAD x to check all arcs the RFS fetched, there was corrupt in every file);
I restore the DR DB again & apply incremental backup from the primary, now it run well. I don't know what's happening as I did the same procedures for all DR DB.
Yesterday night, I have to stop & restart DR site 1. Today, I check and it got the same error as the 2nd site, with corrupted redo. I try to delete the arcs, & let RFS to reget it, but the files were corrupt too.
Currently, dr site 2 is fine, dr site 1 still get the wrong redolog. If this continue to happen with the 2nd site again, that'll be a big problem.
The Primary & DR site 1 is linked by a GB switch, site 2 by a 155Mbps connection (far enough for my db load at about 1.5MB/s avg apply rate).
I seach Oracle support (metalink) but no luck, there is a case but it mentions max_connection>1 (mine is default =1)

Can someone show me how to troubleshooting/debug/trace this problem.
That would be a great help!
Thank you very much.
Previous Topic: Create Standby
Next Topic: How To Switch Oracle Primary And Standby (what was I doing wrong!!)
Goto Forum:

Current Time: Thu Oct 01 14:35:00 CDT 2020